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Installation on MacOS

1. Make sure you enable Python scripting in FontLab Studio -> 
Preferences -> General Options -> Python scripting.

2. Unzip the .zip file.

3. Drag the .flw file onto the FontLab icon in the dock.

4. Restart FontLab or reset the macro system.

The Macro Toolbar

In case the Macro Toolbar is not shown, switch it on at View -> Toolbars -> Macro

Automatic updates

The installer allows you to enable automatic updates. This installs a module that 
regularly checks the Remix Tools web server for new versions and, after confirmation 
by the user, updates the RMX installation. No personal data will be submitted.

This feature can be deactivated at any time by removing the files RMXupdater.py 
and RMXupdater.pyc (if present) from the Macros | System | Modules folder.

These controls are not 
used by the RMX Tools.

The RMX installer allows you to create a subfolder for the macros, 

which will appear in this list. If the macros are installed in the 
standard folder they will appear in the top level category.

You can assign a keyboard shortcut 
to each macro and access it directly 
without using the toolbar.

This button resets the macro system. All entry fields  
in the dialogs are reset to their default values, 
and the Harmonizer’s “remember my chioce” is cancelled.

Choose a macro from the list 
and run it by using the play 
button or with Cmd+R/Ctrl+R.

Installation on Windows

1. In case it is not already installed on your computer 
you need to install Python 2.3, which is available from 
www.python.org/download/releases/2.3.6/. 

2. Unzip the .zip file.

3. Drag the .flw file into the FontLab application window.

4. Restart FontLab or reset the macro system.

FontLab is a trademark of Fontlab Ltd.

Font Remix Tools Getting started

Note that there is only one version of the Font Remix Tools, which is compatible with 
both the Macintosh and Windows versions of FontLab Studio 5.02 or later.

Python 2.3 or 2.4 is required. 

Some of the RMX Tools only work with Multiple Master fonts that have a weight axis.
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RMX Harmonizer

The Harmonizer helps design nice, visually consistent curves 
while it retains the shape as far as possible.

The Harmonizer offers three degrees of smoothness, each of which 
corresponds to a geometrical concept of continuity:

In FontLab, sometimes even nodes that are set to “smooth” can have 
kinks, for example, after interpolation or scaling. Use dekink to make 
sure these connections are really straight. This has a very similar 
effect as double-clicking a smooth node twice but the handles will 
be even better aligned since RMX handles the integer coordinates 
intelligently.

Another condition of visually balanced curve connections is the 
continuity of curvature. Choose harmonize to have the outline 
automaticaly adjusted so that at each node, the radius of the two 
joining curve segments is equal. Note that this process includes 
dekinking.
The next degree of geometric continuity, which the Harmonizer 
refers to as supersmooth, meas that even the change of curvature is 
continuous at the node. In practice, this means that “flattenings” and 
“bumps” cause by added nodes are evened out.

If remember my choice is selected the dialog will not be shown when 
the tool is used th next time and the current setting applied. The 
dialog will come back after restarting FontLab, resetting the macro 
system or by shift-clicking the play button to start the macro. On 
Windows you may need to install the Python for Windows extensions 
to enable this feature. 

Note that the Harmonizer does not modify the shape as a matter of 
principle. How much a glyph gets modified glyph depends entirely 
on the deviation from the required conditions. Consequently, a 
shape that is already harmonious will not be changed at all if the 
Harmonizer is applied to it a second time.
If there is a very abrupt change in curvature the Harmonizer assumes 
it is an intentional design feature and does not treat that node.
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RMX Tuner

Use this tool in the Glyph Window to quickly adjust the current glyph.

Adjust the shape of the glyph, using the + and –  buttons. Shift-click 
the buttons to quickly change the value in larger steps. On Windows 
you may need to install the Python for Windows extensions to enable 
this feature.

The buttons for Width, Height and Weight are only available for MM 
fonts with a weight axis. For MM fonts with multiple axes, additional 
buttons become available for each axis.

The Mask buttons are only available if the glyph has a mask that is 
compatible with the outline but not identical.

By default, the RMX Tuner preserves the sidebearings. Check fixed 
width when working on tabular glyphs or monospaced fonts to retain 
the advance width.

If scale on baseline is not checked the glyphs will be scaled vertically 
on the measurement line. To position the measurement line, make 
sure vertical metrics layer is activated under View -> Show Layers -> 
Vertical Metrics.

This macro needs to know the standard stems of each master. 
Please enter them in File -> Font Info -> Hinting Settings -> Standard 
stems (T1 hinting) -> V stems. Only the first value will be considered.

It is helpful to open a preview/metrics window in addition to the 
glyph window so you can instantly see the changes  in context. 
In metrics mode the RMX Tuner can be used directly from within 
the metrics window.
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RMX Add MM Width Axis

This macro adds a width axis to an MM font that has a weight axis.

The standard stem weights are automatically filled in if standards 
stems are defined in the font’s hinting settings. In order to make use 
of this convenience, enter them in File -> Font Info -> Hinting Settings 
-> Standard stems (T1 hinting) -> V stems. Only the first value of each 
master is considered.

Enter the italic angle of the existing glyphs in order to retain the 
angle in the condensed and extended versions.

The keep stroke setting controls in how far the weight of the 
strokes is retained. For example, 0% means pure geometrical scaling, 
while 100% keeps the stroke weight exactly like it was before. 
Recommended values are 100% for extralight,  90% for regular 
weights and 60%–70% for bold and black weights.

Define how much the new masters will be condensed and extended. 
Set any of the fields to 100% if you want to process only one weight, 
or extend the width range only in one direction.

 keep stroke 100%

 keep stroke 0%

Wt0 Wt1
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RMX Scaler Easy

The standard stem weights are automatically filled in if standards 
stems are defined in the font’s hinting settings. In order to make use 
of this convenience, enter them in File -> Font Info -> Hinting Settings 
-> Standard stems (T1 hinting) -> V stems. Only the first value of each 
master is considered.

The values for width and height control the dimensions of the scaled 
glyphs. Leave the height setting at 100% to generate condensed or 
extended versions.

The stem weight setting controls the weight of the scaled glyphs. 
Enter the stroke weight in units.

Reduced versions such as small caps of superiors generally need 
a looser tracking. Use adjust spacing to increase or decrease the 
sidebearings by a fixed amount while the glyphs are scaled.

Enter a vertical shift when creating superiors, inferiors or 
numerators. Negative values shift the glyph downwards.

Adding a suffix creates scaled copies of the selected glyphs. If no 
suffix is entered, the source glyphs are scaled in place.

Use the preview checkbox to see what the result will look like. Note 
that composites and kerning will not be scaled until OK is pressed.

Run this tool in the Font Window to scale the selected glyphs.

Used in the Glyph Window, the Scaler allows to precisely adjust all 
masters of the current glyph.

100%

100%

Wt0 Wt1
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RMX Scaler

The Scaler has the same functionality as the Scaler Easy, plus further features.

Please refer to the previous page for an explanation of the basic settings.

The standard stem weights are automatically filled in if standards 
stems are defined in the font’s hinting settings. In order to make use 
of this convenience, enter them in File -> Font Info -> Hinting Settings 
-> Standard stems (T1 hinting) -> V stems. Only the first value of each 
master is considered.

Enter the italic angle of the existing glyphs in order to retain the 
angle even when the glyphs are condensed or extended.

The Scaler allows to scale the current selection or restore the 
previous selection that was used the last time the set was applied. 
Alternatively, the macro can automatically select the necessary input 
glyphs based on the added suffix that is specified below, or scale the 
entire font.

If scale sidebearings is not selected, the sidebearings are retained. 
It is highly recommended to scale the sidebearings in most cases.  
If the overall  spacing is too narrow, use adjust spacing.

In case some or all of the input glyphs have a suffix that needs to be 
removed or replaced, choose remove existing suffix.

Enter R G B C M Y or any combination of these letters as the color of 
the scaled glyphs. Note that this is converted to a one-dimensional 
value internally since FontLab only allows to specify the hue.

It is possible to save the set of parameters under the specified name.
All sets are saved the file RMX.txt in the same location as the font 
file. Use the buttons < and > to browse through the saved sets or X to 
delete current set.
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RMX Monospacer

After selecting a number of glyphs in the Font Window, use this tool to create 
a monospaced version.

It is recommended particularly for automatic generation of tabular figures and symbols.

The standard stem weights are automatically filled in if standards 
stems are defined in the font’s hinting settings. In order to make use 
of this convenience, enter them in File -> Font Info -> Hinting Settings 
-> Standard stems (T1 hinting) -> V stems. Only the first value of each 
master is considered.

Enter the italic angle of the existing glyphs in order to retain the 
angle even when the glyphs are condensed or extended.

The Scaler allows to scale the current selection or restore the 
previous selection that was used the last time the set was applied. 
Alternatively, the macro can automatically select the necessary input 
glyphs based on the added suffix that is specified below, or scale the 
entire font.

The advance width that all input glyphs are scaled to, the 
mono width, is automatically filled in with a proposed value. 
This is chosen so that one third of the glyphs will be condensed and 
the others extended.

The keep stroke setting controls in how far the weight of the strokes 
is retained. Recommended values are 100% for extralight,  90% for 
regular weights and 60%–70% for bold and black weights.

In order to monospace the glyphs, the macro extends and condenses 
their shape, but it can also use spacing to adjust the advance width. 
This reduces the changes to the horizontal proportions within the set 
of glyphs but it results in more irregular spacing.

In case some or all of the input glyphs have a suffix that needs to be 
removed or replaced, choose remove existing suffix.

Enter R G B C M Y or any combination of these letters as the color of 
the resulting glyphs. Note that this is converted to a one-dimensional 
value internally since FontLab only allows to specify the hue.

Use the preview checkbox to see what the result will look like. Note 
that composites will not be treated until OK is pressed.

It is possible to save the set of parameters under the specified name.
All sets are saved the file RMX.txt in the same location as the font 
file. Use the buttons < and > to browse through the saved sets or X to 
delete current set.
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RMX Slanter

This tool slants glyphs while keeping vertical tangents upright.

To slant right the glyphs, enter the value in degrees. In order to slant 
left, enter a negative value.

For MM fonts, the Slanter allows to reduce the width of the glyphs, 
as it is often done for italics, and also to adjust the weight.  
The tweak weight value does not refer to the absolute stem weights, 
it represents weight interpolation along the MM axis. See the 
previous pages for information on the standard stem values. 

Use the preview checkbox to see what the result will look like. Note 
that composites will not be threated until OK is pressed.
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RMX Multi Updater

Select the sets you want to apply from the list of sets previously 
saved with the Scaler and the Monospacer.

Note that you need to define and save parameter sets with the Scaler 
or Monospacer first before you can apply them in the Multi Updater. 
The sets are saved in the file RMX.txt in the same location as the font 
file and read from there by the Multi Updater.

This tools applies several previously saved sets at once.


